Установка PtokaX

Есть вопросы по настройке? Что-то работает не так? Спросите здесь.
Asmud
 
Сообщения: 10

Установка PtokaX

Сообщение 10 сен 2014, 16:06

Добрый день!

Подскажите пожалуйста как правильно установить PtokaX на Ubuntu, нашёл вот такую инструкцию:
viewtopic.php?f=10&t=76
но ссылки на сборку не рабочие :о( подскажите зачем что в сборке нужно и как правильно поставить ?

Ptokax_Remote_Admin 2.13 насколько я понял графическая панель управления но для того чтобы её приделать нужно:

1. установить саму PtokaX
2. установить Lua с версией не понятно тема аж 2009 года
непонятно зачем нужны вот енти модули и как их ставить:
LuaFileSystem 1.4.2
LuaSocket 2.0.2
LuaSQL 2.2.0 (mysql, sqlite3)

Вобщем чот завис я тут капитально

Аватара пользователя
slav
 
Хаб: adc://kremlin.ru
 
Сообщения: 617
Откуда: Интернет

Сообщение 11 сен 2014, 01:48

Asmud писал(а):Подскажите пожалуйста как правильно установить PtokaX

Я устанавливал так: ссылка

А вообще, можешь поискать в репазиториях. Для OpenSuse версия 5.0.0 есть.
Но, даже через репазиторий если поставишь, то настраивать и запускать придётся в ручную.

Asmud
 
Сообщения: 10

Сообщение 11 сен 2014, 08:32

slav писал(а):А вообще, можешь поискать в репазиториях. Для OpenSuse версия 5.0.0 есть.


Может сразу новую использовать или старая надёжнее ?

Аватара пользователя
slav
 
Хаб: adc://kremlin.ru
 
Сообщения: 617
Откуда: Интернет

Сообщение 11 сен 2014, 09:51

Asmud писал(а):Может сразу новую использовать или старая надёжнее ?

Это вопрос философский :-)
Кому, что нравиться.

Попробую пованговать. Судя по тому, что у вас Ибунту, а не Дебиан, то вы предпочтёте самую свежую версию. :-)

Asmud
 
Сообщения: 10

Сообщение 11 сен 2014, 13:32

Хм а зачем TinyXml нужен ?

да и Ptokax_Remote_Admin надо бы как то приделать :о) а то как то в консоле не очень умею работать :о)

Asmud
 
Сообщения: 10

Сообщение 11 сен 2014, 14:37

блин не хочет собираться :о(

Код: Выделить всё
dc@dc-desktop:~/PtokaX$ sudo make lua52
/home/dc/PtokaX/core/ZlibUtility.cpp:32:18: fatal error: zlib.h: Нет такого файла или каталога
#include <zlib.h>
^
compilation terminated.
make: *** [/home/dc/PtokaX/obj/ZlibUtility.o] Ошибка 1
dc@dc-desktop:~/PtokaX$


создал каталог думал прокатит :о) не прокатило

Код: Выделить всё
dc@dc-desktop:~/PtokaX$ sudo make lua52
[sudo] password for dc:
g++ -O -g -Wall -Wextra -Itinyxml -Iskein/Optimized_32bit -I/usr/include -I/usr/include/lua5.2 -c /home/dc/PtokaX/core/ZlibUtility.cpp -o /home/dc/PtokaX/obj/ZlibUtility.o
/home/dc/PtokaX/core/ZlibUtility.cpp:32:18: fatal error: zlib.h: Нет такого файла или каталога
#include <zlib.h>
^
compilation terminated.
make: *** [/home/dc/PtokaX/obj/ZlibUtility.o] Ошибка 1
dc@dc-desktop:~/PtokaX$ ^C
dc@dc-desktop:~/PtokaX$ sudo make lua52
cd skein; make
make[1]: Вход в каталог `/home/dc/PtokaX/skein'
g++ -O -Wall -IOptimized_32bit -c /home/dc/PtokaX/skein/Optimized_32bit/skein.c -o /home/dc/PtokaX/skein/obj/skein.o
g++ -O -Wall -IOptimized_32bit -c /home/dc/PtokaX/skein/Optimized_32bit/skein_block.c -o /home/dc/PtokaX/skein/obj/skein_block.o
ar rv skein.a /home/dc/PtokaX/skein/obj/skein.o /home/dc/PtokaX/skein/obj/skein_block.o
ar: создаётся skein.a
a - /home/dc/PtokaX/skein/obj/skein.o
a - /home/dc/PtokaX/skein/obj/skein_block.o
make[1]: Выход из каталога `/home/dc/PtokaX/skein'
cd tinyxml; make
make[1]: Вход в каталог `/home/dc/PtokaX/tinyxml'
make[1]: `tinyxml.a' не требует обновления.
make[1]: Выход из каталога `/home/dc/PtokaX/tinyxml'
g++ /home/dc/PtokaX/obj/colUsers.o /home/dc/PtokaX/obj/DcCommands.o /home/dc/PtokaX/obj/DeFlood.o /home/dc/PtokaX/obj/eventqueue.o /home/dc/PtokaX/obj/GlobalDataQueue.o /home/dc/PtokaX/obj/hashBanManager.o /home/dc/PtokaX/obj/hashUsrManager.o /home/dc/PtokaX/obj/hashRegManager.o /home/dc/PtokaX/obj/HubCommands.o /home/dc/PtokaX/obj/IP2Country.o /home/dc/PtokaX/obj/LanguageManager.o /home/dc/PtokaX/obj/LuaBanManLib.o /home/dc/PtokaX/obj/LuaCoreLib.o /home/dc/PtokaX/obj/LuaIP2CountryLib.o /home/dc/PtokaX/obj/LuaProfManLib.o /home/dc/PtokaX/obj/LuaRegManLib.o /home/dc/PtokaX/obj/LuaScript.o /home/dc/PtokaX/obj/LuaScriptManager.o /home/dc/PtokaX/obj/LuaScriptManLib.o /home/dc/PtokaX/obj/LuaSetManLib.o /home/dc/PtokaX/obj/LuaTmrManLib.o /home/dc/PtokaX/obj/LuaUDPDbgLib.o /home/dc/PtokaX/obj/ProfileManager.o /home/dc/PtokaX/obj/PtokaX.o /home/dc/PtokaX/obj/PXBReader.o /home/dc/PtokaX/obj/pxstring.o /home/dc/PtokaX/obj/RegThread.o /home/dc/PtokaX/obj/ResNickManager.o /home/dc/PtokaX/obj/ServerManager.o /home/dc/PtokaX/obj/ServerThread.o /home/dc/PtokaX/obj/serviceLoop.o /home/dc/PtokaX/obj/SettingManager.o /home/dc/PtokaX/obj/TextFileManager.o /home/dc/PtokaX/obj/UdpDebug.o /home/dc/PtokaX/obj/UDPThread.o /home/dc/PtokaX/obj/User.o /home/dc/PtokaX/obj/utility.o /home/dc/PtokaX/obj/ZlibUtility.o /home/dc/PtokaX/tinyxml/tinyxml.a /home/dc/PtokaX/skein/skein.a -o PtokaX -lstdc++ -lpthread -llua5.2 -lrt -lz
/usr/bin/ld: cannot find /home/dc/PtokaX/obj/ZlibUtility.o: Формат файла не распознан
collect2: error: ld returned 1 exit status
make: *** [lua52] Ошибка 1


не хочет собираться PtokaX с Lua 5.2 можно ли щас её переставить с Lua 5.1 или всё удалять и заного ?

Аватара пользователя
slav
 
Хаб: adc://kremlin.ru
 
Сообщения: 617
Откуда: Интернет

Сообщение 11 сен 2014, 16:05

Код: Выделить всё
apt-get install lua5.2 liblua5.2-dev zlib1g zlib1g-dev g++ 

Код: Выделить всё
apt-get install build-essential

Asmud
 
Сообщения: 10

Сообщение 11 сен 2014, 16:54

slav писал(а):apt-get install lua5.2 liblua5.2-dev zlib1g zlib1g-dev g++

енто команда устанавливает всё сразу енто понятно, толь почему то make нет

slav писал(а):apt-get install build-essential

а что делать вот после этой ?
Последний раз редактировалось Asmud 11 сен 2014, 17:06, всего редактировалось 3 раз(а).

Аватара пользователя
Быстрый ответ
 
Сообщения: 436

Сообщение 11 сен 2014, 17:11

Не пробовали читать документацию разработчика? обычно помогает, если ничто другое не помогло :-) http://wiki.ptokax.org/doku.php?id=guid ... n_bugbuntu

Asmud
 
Сообщения: 10

Сообщение 11 сен 2014, 17:15

Быстрый ответ писал(а):Не пробовали читать документацию разработчика? обычно помогает, если ничто другое не помогло http://wiki.ptokax.org/doku.php?id=guid ... n_bugbuntu


Ты что тут же всё по английски :о) спасибо щас попробую, хм если я щас грохну папку с уже замусоренным PtokaX не будет бедной ubunte плохо от ентого ?

Аватара пользователя
slav
 
Хаб: adc://kremlin.ru
 
Сообщения: 617
Откуда: Интернет

Сообщение 11 сен 2014, 17:34

Asmud писал(а):Ты что тут же всё по английски

В моей ссылке выше всё тоже самое, но по русски.

Asmud
 
Сообщения: 10

Сообщение 11 сен 2014, 17:42

slav писал(а):Asmud писал(а):Ты что тут же всё по английски
В моей ссылке выше всё тоже самое, но по русски.


Да :о) чувствую что что то я не то сделал, но видно зря пробовал поставить TinyXml для чего оно не знаю, но возможно из-за ентого не собирается.

ввёл вот эти команды
apt-get install lua5.2 liblua5.2-dev zlib1g zlib1g-dev g++
slav писал(а):apt-get install build-essential
попытался собрать опять ошибку выдал :о(
Последний раз редактировалось Asmud 11 сен 2014, 17:46, всего редактировалось 1 раз.

Аватара пользователя
slav
 
Хаб: adc://kremlin.ru
 
Сообщения: 617
Откуда: Интернет

Сообщение 11 сен 2014, 17:57

Asmud писал(а):TinyXml для чего оно не знаю, но возможно из-за ентого не собирается.

Ты, вообще, переходил по моей ссылке???
Там же ясно написано по-русски: TinyXml — библиотека для работы с XML-файлами используемыми в PtokaX.

Ты можешь просто поставить по инструкции как там написано без отсебятины?

Asmud
 
Сообщения: 10

Сообщение 11 сен 2014, 18:10

slav писал(а):Asmud писал(а):TinyXml для чего оно не знаю, но возможно из-за ентого не собирается.
Ты, вообще, переходил по моей ссылке???
Там же ясно написано по-русски: TinyXml — библиотека для работы с XML-файлами используемыми в PtokaX.

Ты можешь просто поставить по инструкции как там написано без отсебятины?


Да вроде и ставил всё по инструкции ... хотя была не PtokaX 0.5.0.0 а PtokaX 0.5.0.2 но уже нащёл и PtokaX 0.5.0.0 версию вот щас думаю заного ставить, можно папку старую удалять тут как я понимаю нет понятия реестра ?

Народ не судите строго второй раз линукс ставлю :о)

Аватара пользователя
slav
 
Хаб: adc://kremlin.ru
 
Сообщения: 617
Откуда: Интернет

Сообщение 11 сен 2014, 18:17

Asmud писал(а):хотя была не PtokaX 0.5.0.0 а PtokaX 0.5.0.2

Ставь сразу 0.5.0.2 Ссылка на новую замени и всё http://www.ptokax.org/files/0.5.0.2-nix-src.tgz
Ну и при распаковке архива тоже циферки нужные поставь.
Asmud писал(а):можно папку старую удалять тут как я понимаю нет понятия реестра ?

Удаляй…

Asmud
 
Сообщения: 10

Сообщение 11 сен 2014, 18:41

Алилуя :о) собралась правда с Lua 5.1

Asmud
 
Сообщения: 10

Сообщение 11 сен 2014, 19:04

Как корректно выйти из файла и сохранить его ?


Вернуться в Помощь по DC



Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

cron